You are using an unsupported browser. Please update your browser to the latest version on or before July 31, 2020.
close

There is No LED Activity and My ZEN25 Double Plug is Unresponsive

Plug the ZEN25 Double Plug into a grounded 110VAC receptacle. 

Click the Z-Wave button once to turn on the left outlet, and double-click it to turn on the right outlet. At this point should see the LED indicators turn on and off. If you don't see any LED activity, try moving it to a different receptacle to rule out any grounding issues.

We've added a new feature that allows you to switch between LED indicator modes by clicking the Z-Wave button 6 times quickly. Check that the LED indicator wasn't disabled accidentally by pressing the Z-Wave button 6 more times; this may activate the LEDs. 

If the receptacle is powered and the LEDs are working fine but the device is unresponsive to manual and remote commands, try performing a hard reset on the Double Plug. Just remember that this type of reset will erase all previously recorded activity along with any custom changes you had in place. 

If you notice that the Double Plug became unresponsive after you connected a device or appliance, we also recommend checking here to verify that the connected device is compatible with the plug. Certain devices, like heavy duty equipment, fans, and chargers, will damage the Double Plug.

If the device is still unresponsive after trying the suggestions above, get in touch with us. We'll be happy to help.

  • 262
  • 10-Jun-2020
  • 501 Views