Can't Connect My Power Strip to My Z-Wave System

Let's try excluding the Power Strip first.

Exclusion is kind of like a soft reset. Even if your Power Strip was never successfully included to your Z-Wave hub, it can help a wide variety of issues, from connectivity to configuration to inclusion. Here's how to do it:

1. Plug the Power Strip into a grounded receptacle located within direct range of your Z-Wave hub
2. Put your Z-Wave hub into exclusion mode (see your controller's manual, as each brand is different)
3. Press and release the CH1 button 3 TIMES QUICKLY
4. Your hub will confirm exclusion and all of the channels (child outlets) and the main device will disappear from your controller's device list.

Once exclusion is completed, try re-including the Power Strip to your hub.

If exclusion doesn't help, here are some other things to try:

  • Try the exclusion process once again. It's possible that the commands just didn't go through the first time.
  • Bring the Power Strip closer to your hub. If it includes successfully from a different spot, the previous spot may be out of range. 
  • Once you put the hub into inclusion mode, press and release the CH1 button very quickly more than 3 times to ensure the command has gone through.
  • If you're able to get the unit connected but find that it's become unresponsive in your Z-Wave app interface, it may be a range issue. Here's what to try

If you're still experiencing issues with your Power Strip after trying everything above, please let us know!

  • 166
  • 11-Oct-2018
  • 51 Views